Vocus requires Google Chrome

Hey there! Vocus requires Google Chrome on Mac or PC. Try again using Chrome Desktop and we'll get you up and running in no time.